Ваша тема содержит устаревшие копии некоторых файлов шаблонов WooCommerce

//Ваша тема содержит устаревшие копии некоторых файлов шаблонов WooCommerce

Ваша тема содержит устаревшие копии некоторых файлов шаблонов WooCommerce

Поскольку мы знаем, что woocommerce – это широко используемый плагин на базе WordPress для веб-сайтов шоппинга и электронной коммерции. Это очень хороший плагин, с большой комьюнити и хорошей поддержкой. Обычно мы обновляем WordPress и плагины регулярно, чтобы обеспечить безопасность. Поэтому, чтобы сделать возможными обновления, не рекомендуется модифицировать любой файл ядра WordPress, а также файлы плагина.

Поэтому, чтобы избежать этого, мы перезаписываем некоторые часто используемые файлы в темах. В случае woocommerce мы подготовим папку в теме под названием «woocommerce», скопируем файл шаблона и вставим в папку в теме, чтобы переопределить его. Иногда мы получаем сообщение об ошибке в нашей панели инструментов, например « Ваша тема содержит устаревшие копии некоторых файлов шаблонов WooCommerce. Эти файлы могут нуждаться в обновлении, чтобы обеспечить их совместимость с текущей версией WooCommerce ».

Причина : мы изменили несколько файлов во время работы, но когда плагин выпускает свою новую версию, мы обновляем ее, но файлы, которые мы поместили в нашу тему, по-прежнему имеют приоритет над содержимым предыдущей версии.

Теперь давайте возьмем пример файла старой версии (не обновленного) woocoomerce, чтобы понять его более подходящим образом.

Старая версия «/woocommerce/cart/cart-item-data.php»:

Новая версия “/woocommerce/cart/cart-item-data.php” :

Решение: нам нужно заменить файлы предыдущей версии на новую. Для этого выполните следующие действия:

1. Перейдите к admin => woocommerce => System Status и затем прокрутите вниз до нижней части страницы, вы увидите экран, как показано ниже:

2. Теперь скопируйте код файла по умолчанию и перейдите в файл, затем замените его новой версией текущего плагина.

3. Сохраните изменения и снова перейдите к admin => woocommerce => System Status, сообщение об устаревшей версии из этого конкретного файла было удалено.

Таким образом, нужно обновить каждый файл, который указан здесь, и получить последнюю версию wocommerce. После этого сообщение об ошибке, которое мы получаем в админ-панели, исчезнет автоматически.

От |2019-05-14T16:48:03+00:00Май 15th, 2019|Woocommerce|Нет комментариев

О авторе:

Я занимаюсь веб-разработкой и freelance более 4-х лет, ранее работал 5 лет в банковской сфере, в отделе it-технологий. Специализируюсь на таких популярных CMS: WordPress, Drupal и Joomla. Разрабатываю сайты любой сложности, среди которых: блоги, landing page (лендинги), интернет-магазины, сайты-визитки, корпоративные сайты и прочее.

Оставить комментарий